'); })();

Magento Connect 安装插件提示 PHP 版本不兼容

Magento Connect 安装插件时提示 PHP 版本不兼容: requires PHP version 。

原因是为了插件更好的兼容系统,一般插件会限制一个 PHP 版本的范围,在 package.xml 里,如:

<dependencies><required><php><min>5.3.0</min><max>7.0.0</max></php><extension><name>curl</name><min/><max/></extension></required></dependencies>

如果我们的 PHP 版本不在这个范围就会报错。

如果插件真的没办法在你的 PHP 版本运行,那你只能升级你的 PHP 版本了。

而很多情况是它只作了限制,却可以在其他版本运行,这这情况也是可以解决的。

解决办法:先把插件下载下来,下载方法参见:

Magento Connect 插件安装包文件的下载方法

下载后有两种办法安装:

一、直接解压上传到magento网站系统上;

二、解压修改  package.xml 里对应的 PHP 版本限制范围,改到包括你的 PHP 版本即可,然后在后台 Magento Connect 上传安装包安装。

这里要注意的是第二种方法里边的文件压缩问题,如果压缩方法不对,上传安装还是会报错,如:

CONNECT ERROR: Package file is invalid
Invalid package name, allowed: [a-zA-Z0-9_-] chars
Invalid version, should be like: x.x.x
Invalid stability
Invalid date, should be YYYY-DD-MM
Invalid channel URL
Empty authors section
Empty package contents section

这时要进入解压完的文件夹里,用命令压缩:

# tar -cvzf MyModule.tgz app package.xml skin app js(这里看你的插件根目录有包含哪些文件夹或文件)

这样压缩好的文件就可以用来上传安装了。

相关文章